Back to overview
Downtime
Service Unavailable
Nov 13, 2023 at 06:56am UTC
Resolved
Nov 28, 2023 at 11:04am UTC
Replacement machine has been delivered and all services are back up and running!
Affected services
Updated
Nov 23, 2023 at 07:09am UTC
Empyrion server has been migrated to new NA4 machine, host is still working on resolving the issues with the NA3 machine!
Affected services
Created
Nov 13, 2023 at 06:56am UTC
Our Dedicated machine hosting Empyrion and Rust 2x & Battlefield servers has gone down, we're working with the host to resolve the issues!
Affected services